Support

Issues and requests for the ePUBTools can be followed and reported on this site.

Below are some frequently asked questions.

ePUB-Tools (7)

The first option is that the Visual Studio Tools for Office 2010 are not yet installed. This is common for Office 2007.

This runtime often changes location at Microsoft, but as of January 6th 2016 they can be found here.

Permalink


Mutliple logs are maintained. The log of the add-in itself is kept in %appdata%\Toxaris and is called ePUBTools.log. Not everything is kept there, but it can give an indication.

Windows and office also keep logs. These can be examined with the Event Viewer. The logs for Office can be found as displayed below.
eventviewer_office.JPG

I advise to check the logs immediately after reinstalling and activating the add-in. Make sure that the latest messages appear at the top by clicking on the date/time column. Check the messages (especially warnings or errors) that relate to the add-in.

Permalink

0 Comments - Leave a Comment

If Word is not closed in a normal way, it may happen that the add-in will not start automatically. Usually a question will be asked whether the add-in should be loaded. If it is answered ‘no’ or if the question is not asked, the add-in will be disabled. To enable it later, the following actions must be performed.

  1. Go to Options (under the Office button in Word 2007 and Word 2010, under File in Word 2013)
  2. Go to Add-ins
  3. The add-in is displayed under ‘disabled
  4. Select ‘disabled items’ under managed and press ‘Go
  5. Start the add-in

Permalink


Sometimes Word is already active by another program (e.g. Firefox). This is not always visible. It can cause the ribbon not to appear after starting Word, since Word was still active. This can be checked by using Taskmanager.

Permalink

0 Comments - Leave a Comment

It might be that the configuration file is corrupt. Check the file ePUBTools.cfg (%appdata%\Toxaris). If it does not contain all settings but is very short, it can cause the ePUB Tools not to load.

Check if there is a file ePUBTools.backup. If so, it should be a full backup of the configuration file. Rename the file and restart Word. Open the settings and save them to create a new backup file.

If there is no backup file, delete the configuration file and restart Word. Caution: all settings must be set again.

Permalink

0 Comments - Leave a Comment

It can happen that the ribbon is never visible when Word is started, even when Word is closed correctly. If that is the case, you can check the following. Ensure that Word is not started.

Start regedit and go to HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins\Toxaris.ePUB Tools

Examine the value of key ‘LoadBehavior’, it should be 3. If this is not the case, you can set it to 3.

Permalink


In order to be able to use the ePUB Tools the following components are required:

  • .Net Framework 4.0 (Client profile is sufficient)
  • VSTO 2010 runtime
  • Word 2007 or higher

Permalink


FontShrinker (3)

Before FontShrinker can work on Linux/OSX, mono must be available on the system. On Debian-gebased distributions this can be done with: sudo apt-get install mono-complete

Permalink


To be able to use this program, the following components are required:

  • .Net Framework 4.0 (Client profile is sufficient)

Permalink


If Mono gives this error while starting the application on Unix/Linux/OSX, there is a missing component from Mono. This can even happen if Mono is installed as  mono-complete. The solution is of course to install the missing component. For Debian based linux distributions this can be done with:  sudo apt-get install mono-vbnc

Permalink


ePUBOptimizer (3)

Before ePUBOptimizer can work on Linux/OSX, some additional applications must be available on the system:

  • Mono
  • jpegtran
  • optipng
  • gifsicle

On Debian-gebased distributions this can be done with: sudo apt-get install mono-complete libjpeg-progs gifsicle optipng

Permalink


To be able to use this program, the following components are required:

  • .Net Framework 4.0 (Client profile is sufficient)

Permalink


If Mono gives this error while starting the application on Unix/Linux/OSX, there is a missing component from Mono. This can even happen if Mono is installed as  mono-complete. The solution is of course to install the missing component. For Debian based linux distributions this can be done with:  sudo apt-get install mono-vbnc

Permalink


Toxaris © 2015 Frontier Theme